What’s Vulnerable › Vulnerabilities
CVE-2026-43018: Bluetooth: hci_event: fix potential UAF in hci_le_remote_conn_param_req_evt
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-01 · updated 2026-10-19
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: Bluetooth: hci_event: fix potential UAF in hci_le_remote_conn_param_req_evt hci_conn lookup and field access must be covered by hdev lock in hci_le_remote_conn_param_req_evt, otherwise it's possible it is freed concurrently. Extend the hci_dev_lock critical section to cover all conn usage.
Affected products
- Linux kernel: from 5.17 before 6.1.168; from 6.2 before 6.6.134; from 6.7 before 6.12.81; from 6.13 before 6.18.22; from 6.19 before 6.19.12; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5, 7.0-rc6 — fixed in 6.1.168, 6.12.81, 6.18.22, 6.19.12, 6.6.134
How to fix
Upgrade to a fixed version: Linux kernel 6.1.168, 6.12.81, 6.18.22, 6.19.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1d0bdbfe3e91c11f0a704c52443a9446a10d699c
- https://git.kernel.org/stable/c/59eecf0ffde15670e6a5e10c47be67f73d843b20
- https://git.kernel.org/stable/c/5fb69e1eeea9d6cba80517e9f058b56b34bc3a81
- https://git.kernel.org/stable/c/7cadb03be37e761130edb153544fe0770a842b19
- https://git.kernel.org/stable/c/b255531b27da336571411248c2a72a350662bd09
- https://git.kernel.org/stable/c/ea3cd36d7382d5f8309df04c275d20df139ed42c
Get alerted when CVE-2026-43018 or the next vulnerability affects your stack