What’s Vulnerable › Vulnerabilities
CVE-2026-43077: crypto: algif_aead - Fix minimum RX size check for decryption
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: crypto: algif_aead - Fix minimum RX size check for decryption The check for the minimum receive buffer size did not take the tag size into account during decryption. Fix this by adding the required extra length.
Affected products
- Linux kernel: from 4.14.1 before 5.10.254; from 5.11 before 5.15.204; from 5.16 before 6.1.170; from 6.2 before 6.6.136; from 6.7 before 6.12.83; from 6.13 before 6.18.24 — fixed in 5.10.254, 5.15.204, 6.1.170, 6.12.83, 6.18.24, 6.19.14
How to fix
Upgrade to a fixed version: Linux kernel 5.10.254, 5.15.204, 6.1.170, 6.12.83. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1c76b5675119f694458293a2a81f40731c69bd32
- https://git.kernel.org/stable/c/3afdc15d6173614d7d834517d9b65e7aa5a08548
- https://git.kernel.org/stable/c/3d14bd48e3a77091cbce637a12c2ae31b4a1687c
- https://git.kernel.org/stable/c/74a66fdb5282d89e348b00c42cfca3a936946d94
- https://git.kernel.org/stable/c/78cea133daf721698876e56135049a96d39d610a
- https://git.kernel.org/stable/c/af2fa2fbbced26129813274b8b3f7705f280e174
- https://git.kernel.org/stable/c/e86ab1e5661386a874fbb8551f0c04b8e9f8ad22
- https://git.kernel.org/stable/c/fd427dd84f224309afbcc2cb67c7bb770a01265c
Get alerted when CVE-2026-43077 or the next vulnerability affects your stack