What’s Vulnerable › Vulnerabilities
CVE-2026-43081: net: ipa: fix GENERIC_CMD register field masks for IPA v5.0+
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: net: ipa: fix GENERIC_CMD register field masks for IPA v5.0+ Fix the field masks to match the hardware layout documented in downstream GSI (GSI_V3_0_EE_n_GSI_EE_GENERIC_CMD_*). Notably this fixes a WARN I was seeing when I tried to send "stop" to the MPSS remoteproc while IPA was up.
Affected products
- Linux kernel: from 6.4 before 6.6.136; from 6.7 before 6.12.83; from 6.13 before 6.18.24; from 6.19 before 6.19.14; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5, 7.0-rc6 (+1) — fixed in 6.12.83, 6.18.24, 6.19.14, 6.6.136
How to fix
Upgrade to a fixed version: Linux kernel 6.12.83, 6.18.24, 6.19.14, 6.6.136. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2aa50d2c1f631b405849da246043c6f683af7489
- https://git.kernel.org/stable/c/9709b56d908acc120fe8b4ae250b3c9d749ea832
- https://git.kernel.org/stable/c/a7d326dfb13b5a0763eccfd78836fe15199fc499
- https://git.kernel.org/stable/c/bafc45ea30d297002750396d5f10e3018bf2cd60
- https://git.kernel.org/stable/c/d1c66396796f23f7201b1addf06f62515035354d
Get alerted when CVE-2026-43081 or the next vulnerability affects your stack