What’s Vulnerable › Vulnerabilities
CVE-2026-43093: xsk: tighten UMEM headroom validation to account for tailroom and min frame
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-10-19
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: xsk: tighten UMEM headroom validation to account for tailroom and min frame The current headroom validation in xdp_umem_reg() could leave us with insufficient space dedicated to even receive minimum-sized ethernet frame. Furthermore if multi-buffer would come to play then skb_shared_info stored at the end of XSK frame would be corrupted. HW typically works with 128-aligned sizes so let us provide this value as bare minimum. Multi-buffer setting is known later in the configuration process so besides accounting for 128 bytes, let us also take care of tailroom space upfront.
Affected products
- Linux kernel: from 4.19.118 before 4.20; from 5.4.35 before 5.5; from 5.6.7 before 5.7; from 5.7.1 before 6.6.136; from 6.7 before 6.12.83; from 6.13 before 6.18.24 — fixed in 4.20, 5.5, 5.7, 6.12.83, 6.18.24, 6.19.14
How to fix
Upgrade to a fixed version: Linux kernel 4.20, 5.5, 5.7, 6.12.83. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0ec4d3f6e6934deb843b561ae048cd17218e5ad1
- https://git.kernel.org/stable/c/1a6051cd7e3e4c54ff3854a43b638b9292af5e67
- https://git.kernel.org/stable/c/5f123bc278bf4e3283d8606321bebbfd299f4384
- https://git.kernel.org/stable/c/6523bc1b40e69301f24c14338b762af4739d6d39
- https://git.kernel.org/stable/c/8769708add9eadeea8041a9761771bb715a87104
- https://git.kernel.org/stable/c/9ea6ba4f3195dcba6e8b3e7b2e748593b7cafb12
- https://git.kernel.org/stable/c/a03975beb9f6af0d8ac051e30b2abeabe618414f
- https://git.kernel.org/stable/c/a315e022a72d95ef5f1d4e58e903cb492b0ad931
- https://cert-portal.siemens.com/productcert/html/ssa-784472.html
Get alerted when CVE-2026-43093 or the next vulnerability affects your stack