What’s Vulnerable › Vulnerabilities
CVE-2026-43103: net: lapbether: handle NETDEV_PRE_TYPE_CHANGE
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: net: lapbether: handle NETDEV_PRE_TYPE_CHANGE lapbeth_data_transmit() expects the underlying device type to be ARPHRD_ETHER. Returning NOTIFY_BAD from lapbeth_device_event() makes sure bonding driver can not break this expectation.
Affected products
- Linux kernel: from 2.6.24 before 6.6.136; from 6.7 before 6.12.83; from 6.13 before 6.18.24; from 6.19 before 6.19.14; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5, 7.0-rc6 (+1) — fixed in 6.12.83, 6.18.24, 6.19.14, 6.6.136
How to fix
Upgrade to a fixed version: Linux kernel 6.12.83, 6.18.24, 6.19.14, 6.6.136. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/328bb2cff5c2ed973f595ded769e15f4b7a117be
- https://git.kernel.org/stable/c/363a38044b8cd5b496d241651a1fb666e7c5fe3e
- https://git.kernel.org/stable/c/63851f60781aa89258c8f0952cd13940aab0888e
- https://git.kernel.org/stable/c/698642a01d53107ce9b3fc08bd801284af478a2b
- https://git.kernel.org/stable/c/a10570973619cba9dfa6d723177251b846fae587
- https://git.kernel.org/stable/c/b117056768ab7deb434e7d72065e48d2083a0c2a
- https://git.kernel.org/stable/c/b120e4432f9f56c7103133d6a11245e617695adb
- https://git.kernel.org/stable/c/ffc5ed59f6dc87c51e8775f002619310225742e8
Get alerted when CVE-2026-43103 or the next vulnerability affects your stack