What’s Vulnerable › Vulnerabilities
CVE-2026-43108: soc: qcom: pd-mapper: Fix element length in servreg_loc_pfr_req_ei
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: soc: qcom: pd-mapper: Fix element length in servreg_loc_pfr_req_ei It looks element length declared in servreg_loc_pfr_req_ei for reason not matching servreg_loc_pfr_req's reason field due which we could observe decoding error on PD crash. qmi_decode_string_elem: String len 81 >= Max Len 65 Fix this by matching with servreg_loc_pfr_req's reason field.
Affected products
- Linux kernel: from 6.11 before 6.12.83; from 6.13 before 6.18.24; from 6.19 before 6.19.14; 7.0-rc1, 7.0-rc2, 7.0-rc3, 7.0-rc4, 7.0-rc5, 7.0-rc6 (+1) — fixed in 6.12.83, 6.18.24, 6.19.14
How to fix
Upgrade to a fixed version: Linux kernel 6.12.83, 6.18.24, 6.19.14. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/641f6fda143b879da1515f821ee475073678cf2a
- https://git.kernel.org/stable/c/7d75145672cf2ec7c5417e3243af72c48314f7bb
- https://git.kernel.org/stable/c/c93ca7c5a72e23a83a0b96f7f5c41a7a72f1dc47
- https://git.kernel.org/stable/c/cba84132c2ac7c08b215ce4962bc6f522c08a88c
Get alerted when CVE-2026-43108 or the next vulnerability affects your stack