What’s Vulnerable › Vulnerabilities
CVE-2026-4313: Stored XSS in AdaptiveGRC
- Severity: low (CVSS 2.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-24 · updated 2026-10-26
- Weakness: CWE-79
Description
AdaptiveGRC is vulnerable to Stored XSS via text type fields across the forms. Authenticated attacker can replace the value of the text field in the HTTP POST request. Improper parameter validation by the server results in arbitrary JavaScript execution in the victim's browser. Critically, this may allow the attacker to obtain the administrator authentication token and perform arbitrary actions with administrative privileges, which could lead to further compromise. This issue occurs in versions released before December 2025.
Affected products
- C&F AdaptiveGRC: from 5.420.00 before 5.420.66; from 5.420.00 before 5.444.119; from 5.420.00 before 5.448.116; from 5.420.00 before 5.453.110; from 5.420.00 before 5.454.64; from 5.420.00 before 5.455.87 — fixed in 5.420.14, 5.420.66, 5.423.7, 5.444.119, 5.444.20, 5.448.116
How to fix
Upgrade to a fixed version: C&F AdaptiveGRC 5.420.14, 5.420.66, 5.423.7, 5.444.119. Check the vendor advisory for mitigations.
References
- https://adaptivegrc.com/pl/wszystkie-procesy-grc-w-jednym-narzedziu/
- https://cert.pl/posts/2026/04/CVE-2026-4313
Get alerted when CVE-2026-4313 or the next vulnerability affects your stack