What’s Vulnerable › Vulnerabilities
CVE-2026-43130: iommu/vt-d: Flush dev-IOTLB only when PCIe device is accessible in scalable mode
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: iommu/vt-d: Flush dev-IOTLB only when PCIe device is accessible in scalable mode Commit 4fc82cd907ac ("iommu/vt-d: Don't issue ATS Invalidation request when device is disconnected") relies on pci_dev_is_disconnected() to skip ATS invalidation for safely-removed devices, but it does not cover link-down caused by faults, which can still hard-lock the system. For example, if a VM fails to connect to the PCIe device, "virsh destroy" is executed to release resources and isolate the fault, but a hard-lockup occurs while releasing the group fd. Call Trace: qi_submit_sync qi_flush_dev_iotlb intel_pasid_tear_down_entry device_block_translation blocking_domain_attach_dev __iommu_attach_device __iommu_device_set_domain __iommu_group_set_domain_internal iommu_detach_group vfio_iommu_type1_detach_group vfio_group_detach_container vfio_group_fops_release __fput Although pci_device_is_present() is slower than pci_dev_is_disconnected(), it still takes only ~70 µs on a ConnectX-5 (8 GT/s, x2) and becomes even faster as PCIe speed and width increase. Besides, devtlb_invalidation_with_pasid() is called only in the paths below, which are far less frequent than memory map/unmap. 1. mm-struct release 2. {attach,release}_dev 3. set/remove PASID 4. dirty-tracking setup The gain in system stability far outweighs the negligible cost of using pci_device_is_present() instead of pci_dev_is_disconnected() to decide when to skip ATS invalidation, especially under GDR high-load conditions.
Affected products
- Linux kernel: from 5.10.214 before 5.10.252; from 5.15.153 before 5.15.202; from 6.1.83 before 6.1.165; from 6.6.23 before 6.6.128; from 6.7.11 before 6.8; from 6.8.2 before 6.12.75 — fixed in 5.10.252, 5.15.202, 6.1.165, 6.12.75, 6.18.16, 6.19.6
How to fix
Upgrade to a fixed version: Linux kernel 5.10.252, 5.15.202, 6.1.165, 6.12.75. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/01aed2f1d7cb8fdf4c60c5bb4727608cb82b401d
- https://git.kernel.org/stable/c/0da6697e577023d8867c7beb2d16a22510e4eea9
- https://git.kernel.org/stable/c/10e60d87813989e20eac1f3eda30b3bae461e7f9
- https://git.kernel.org/stable/c/581ce094d9eafb78ec4f9de77bd24b780c151236
- https://git.kernel.org/stable/c/9813306610d0d718c863aaa70928bf57d7570ec0
- https://git.kernel.org/stable/c/9deaacc8dcaddb6ddc5b52e1e63b457450ec0f94
- https://git.kernel.org/stable/c/e2c78c69f8faf2885ea4ceee08c71ac738f401a0
- https://git.kernel.org/stable/c/ead67d0378e90f419e385a43af29435242d80c12
Get alerted when CVE-2026-43130 or the next vulnerability affects your stack