What’s Vulnerable › Vulnerabilities
CVE-2026-43133: KVM: nSVM: Always use vmcb01 in VMLOAD/VMSAVE emulation
- Severity: high (CVSS 7.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-10-19
- Weakness: CWE-754
Description
In the Linux kernel, the following vulnerability has been resolved: KVM: nSVM: Always use vmcb01 in VMLOAD/VMSAVE emulation Commit cc3ed80ae69f ("KVM: nSVM: always use vmcb01 to for vmsave/vmload of guest state") made KVM always use vmcb01 for the fields controlled by VMSAVE/VMLOAD, but it missed updating the VMLOAD/VMSAVE emulation code to always use vmcb01. As a result, if VMSAVE/VMLOAD is executed by an L2 guest and is not intercepted by L1, KVM will mistakenly use vmcb02. Always use vmcb01 instead of the current VMCB.
Affected products
- Linux kernel: from 5.13 before 5.15.202; from 5.16 before 6.1.165; from 6.2 before 6.6.128; from 6.7 before 6.12.75; from 6.13 before 6.18.16; from 6.19 before 6.19.6 — fixed in 5.15.202, 6.1.165, 6.12.75, 6.18.16, 6.19.6, 6.6.128
How to fix
Upgrade to a fixed version: Linux kernel 5.15.202, 6.1.165, 6.12.75, 6.18.16. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0004ecb798b30e90d7ebfe74efae2d9423315a64
- https://git.kernel.org/stable/c/10063e1251c1485034a018236080792ad083dcc5
- https://git.kernel.org/stable/c/127ccae2c185f62e6ecb4bf24f9cb307e9b9c619
- https://git.kernel.org/stable/c/3880e331b0b31d0d5d3702b124f6c93539cd478a
- https://git.kernel.org/stable/c/c3b7015000988ba35ecd5648f4b2283960f00543
- https://git.kernel.org/stable/c/d464cf1ed900d47c85393d40b00017b6adfc2e6c
- https://git.kernel.org/stable/c/fce2fd4a2ca05670a91015aacccf96a1c26268fd
- https://access.redhat.com/errata/RHSA-2026:65334
- https://access.redhat.com/errata/RHSA-2026:66180
- https://access.redhat.com/errata/RHSA-2026:66357
- https://access.redhat.com/errata/RHSA-2026:67468
- https://access.redhat.com/errata/RHSA-2026:67469
Get alerted when CVE-2026-43133 or the next vulnerability affects your stack