What’s Vulnerable › Vulnerabilities
CVE-2026-43171: EFI/CPER: don't dump the entire memory region
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-06-17
- Weakness: CWE-191
Description
In the Linux kernel, the following vulnerability has been resolved: EFI/CPER: don't dump the entire memory region The current logic at cper_print_fw_err() doesn't check if the error record length is big enough to handle offset. On a bad firmware, if the ofset is above the actual record, length -= offset will underflow, making it dump the entire memory. The end result can be: - the logic taking a lot of time dumping large regions of memory; - data disclosure due to the memory dumps; - an OOPS, if it tries to dump an unmapped memory region. Fix it by checking if the section length is too small before doing a hex dump. [ rjw: Subject tweaks ]
Affected products
- Linux kernel: from 5.7 (excl.) before 5.10.252; from 5.11 before 5.15.202; from 5.16 before 6.1.165; from 6.2 before 6.6.128; from 6.7 before 6.12.75; from 6.13 before 6.18.16 — fixed in 5.10.252, 5.15.202, 6.1.165, 6.12.75, 6.18.16, 6.19.6
How to fix
Upgrade to a fixed version: Linux kernel 5.10.252, 5.15.202, 6.1.165, 6.12.75. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/02de64ab54b4bb0f1b21bb324aeff3b08612be33
- https://git.kernel.org/stable/c/0e09b522f2622841389c3b2f9ac4969e35c0809d
- https://git.kernel.org/stable/c/54e131db4cdffd946db890ff33ff2647053fd4f6
- https://git.kernel.org/stable/c/55cc6fe5716f678f06bcb95140882dfa684464ec
- https://git.kernel.org/stable/c/5a9b1dda8481b82851a655c3bcc5b44879b95334
- https://git.kernel.org/stable/c/64ae5aaa7ac93c83da456039e8ec747bfa8a7cff
- https://git.kernel.org/stable/c/7780c0bad2a3a70a8c0113a33c02f4151d901eb3
- https://git.kernel.org/stable/c/a8419f5f2c5f2d80848ddabb2b95cf0da84a5f91
Get alerted when CVE-2026-43171 or the next vulnerability affects your stack