What’s Vulnerable › Vulnerabilities
CVE-2026-43212: LoongArch: Make cpumask_of_node() robust against NUMA_NO_NODE
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: LoongArch: Make cpumask_of_node() robust against NUMA_NO_NODE The arch definition of cpumask_of_node() cannot handle NUMA_NO_NODE - which is a valid index - so add a check for this.
Affected products
- Linux kernel: from 5.19 before 6.1.165; from 6.2 before 6.6.128; from 6.7 before 6.12.75; from 6.13 before 6.18.16; from 6.19 before 6.19.6 — fixed in 6.1.165, 6.12.75, 6.18.16, 6.19.6, 6.6.128
How to fix
Upgrade to a fixed version: Linux kernel 6.1.165, 6.12.75, 6.18.16, 6.19.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1d8f2f024801019d85159a020b72a4424b46bcf4
- https://git.kernel.org/stable/c/61a56df2fbaad3a4d00f0c6a904b5d1ee8982eb4
- https://git.kernel.org/stable/c/92adfb707beec0fe956424373654a70aad35ea13
- https://git.kernel.org/stable/c/94b0c831eda778ae9e4f2164a8b3de485d8977bb
- https://git.kernel.org/stable/c/b5bf05e05cdf489a04137e4da407de9d4cca5295
- https://git.kernel.org/stable/c/bb1a54f7f011f19ed936632698eae574e0b91063
Get alerted when CVE-2026-43212 or the next vulnerability affects your stack