What’s Vulnerable › Vulnerabilities
CVE-2026-43256: media: qcom: camss: vfe: Fix out-of-bounds access in vfe_isr_reg_update()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: media: qcom: camss: vfe: Fix out-of-bounds access in vfe_isr_reg_update() vfe_isr() iterates using MSM_VFE_IMAGE_MASTERS_NUM(7) as the loop bound and passes the index to vfe_isr_reg_update(). However, vfe->line[] array is defined with VFE_LINE_NUM_MAX(4): struct vfe_line line[VFE_LINE_NUM_MAX]; When index is 4, 5, 6, the access to vfe->line[line_id] exceeds the array bounds and resulting in out-of-bounds memory access. Fix this by using separate loops for output lines and write masters.
Affected products
- Linux kernel: from 5.18 before 6.1.167; from 6.2 before 6.6.128; from 6.7 before 6.12.75; from 6.13 before 6.18.16; from 6.19 before 6.19.6 — fixed in 6.1.167, 6.12.75, 6.18.16, 6.19.6, 6.6.128
How to fix
Upgrade to a fixed version: Linux kernel 6.1.167, 6.12.75, 6.18.16, 6.19.6. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0c074e80921fd18984b75836730d76c768c84f65
- https://git.kernel.org/stable/c/1b103307df6d461a0731be25aca69ad0335b0933
- https://git.kernel.org/stable/c/d965919af524e68cb2ab1a685872050ad2ee933d
- https://git.kernel.org/stable/c/e6cbf765686fb6c1d8f2530b3daf6c66efc92f5d
- https://git.kernel.org/stable/c/e7a38ecda2498e7ce998793ac2a46ca47317635d
- https://git.kernel.org/stable/c/fade67c88870f497a13ed450ba01f7236c92dd9b
Get alerted when CVE-2026-43256 or the next vulnerability affects your stack