What’s Vulnerable › Vulnerabilities
CVE-2026-43266: EFI/CPER: don't go past the ARM processor CPER record buffer
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: EFI/CPER: don't go past the ARM processor CPER record buffer There's a logic inside GHES/CPER to detect if the section_length is too small, but it doesn't detect if it is too big. Currently, if the firmware receives an ARM processor CPER record stating that a section length is big, kernel will blindly trust section_length, producing a very long dump. For instance, a 67 bytes record with ERR_INFO_NUM set 46198 and section length set to 854918320 would dump a lot of data going a way past the firmware memory-mapped area. Fix it by adding a logic to prevent it to go past the buffer if ERR_INFO_NUM is too big, making it report instead: [Hardware Error]: Hardware error from APEI Generic Hardware Error Source: 1 [Hardware Error]: event severity: recoverable [Hardware Error]: Error 0, type: recoverable [Hardware Error]: section_type: ARM processor error [Hardware Error]: MIDR: 0xff304b2f8476870a [Hardware Error]: section length: 854918320, CPER size: 67 [Hardware Error]: section length is too big [Hardware Error]: firmware-generated error record is incorrect [Hardware Error]: ERR_INFO_NUM is 46198 [ rjw: Subject and changelog tweaks ]
Affected products
- Linux kernel: from 4.13 before 5.10.252; from 5.11 before 5.15.202; from 5.16 before 6.1.165; from 6.2 before 6.6.128; from 6.7 before 6.12.75; from 6.13 before 6.18.16 — fixed in 5.10.252, 5.15.202, 6.1.165, 6.12.75, 6.18.16, 6.19.6
How to fix
Upgrade to a fixed version: Linux kernel 5.10.252, 5.15.202, 6.1.165, 6.12.75. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/25b290624b0e3d2f0f90238709ee0b6009b9fde8
- https://git.kernel.org/stable/c/45766863baf899059e75595dd3cb1116467f2095
- https://git.kernel.org/stable/c/64eb63f573f497553e1a0c388bbcdd639e0f0704
- https://git.kernel.org/stable/c/a68d22902a6916e10ee235fee609239004e129d0
- https://git.kernel.org/stable/c/be10c1bdf64a39832998f54900aa309b3917abcf
- https://git.kernel.org/stable/c/c80113dcfc807308f5ab33847fae77e07531aeb8
- https://git.kernel.org/stable/c/ca2aad8771aa9091bc9e42e7d546bd40b72ddcd4
- https://git.kernel.org/stable/c/eae21beecb95a3b69ee5c38a659f774e171d730e
Get alerted when CVE-2026-43266 or the next vulnerability affects your stack