What’s Vulnerable › Vulnerabilities
CVE-2026-43328: cpufreq: governor: fix double free in cpufreq_dbs_governor_init() error path
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-06-17
- Weakness: CWE-415
Description
In the Linux kernel, the following vulnerability has been resolved: cpufreq: governor: fix double free in cpufreq_dbs_governor_init() error path When kobject_init_and_add() fails, cpufreq_dbs_governor_init() calls kobject_put(&dbs_data->attr_set.kobj). The kobject release callback cpufreq_dbs_data_release() calls gov->exit(dbs_data) and kfree(dbs_data), but the current error path then calls gov->exit(dbs_data) and kfree(dbs_data) again, causing a double free. Keep the direct kfree(dbs_data) for the gov->init() failure path, but after kobject_init_and_add() has been called, let kobject_put() handle the cleanup through cpufreq_dbs_data_release().
Affected products
- Linux kernel: from 5.2 before 5.10.253; from 5.11 before 6.1.168; from 6.2 before 6.6.134; from 6.7 before 6.12.81; from 6.13 before 6.18.22; from 6.19 before 6.19.12 — fixed in 5.10.253, 6.1.168, 6.12.81, 6.18.22, 6.19.12, 6.6.134
How to fix
Upgrade to a fixed version: Linux kernel 5.10.253, 6.1.168, 6.12.81, 6.18.22. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/019ea28629720c220daedf38107c8787f330dc05
- https://git.kernel.org/stable/c/3bf9d023d2329a0e5379f2fd09d06ef09729cd9d
- https://git.kernel.org/stable/c/427d048e4f6acbfa01b5a8062449fe0ee8987c0d
- https://git.kernel.org/stable/c/4b9118e93d2499bb2808ef3742fa0ce06f4f8117
- https://git.kernel.org/stable/c/56bc91ee78babe9578585a2bc137abc4b3115ff3
- https://git.kernel.org/stable/c/6dcf9d0064ce2f3e3dfe5755f98b93abe6a98e1e
- https://git.kernel.org/stable/c/d2703b4f8fb7cc6f0dfdb2dc2359cc46189e7357
- https://git.kernel.org/stable/c/da39ee627fd82b52068d4d5f115749a8b7d271f9
Get alerted when CVE-2026-43328 or the next vulnerability affects your stack