What’s Vulnerable › Vulnerabilities
CVE-2026-43334: Bluetooth: SMP: force responder MITM requirements before building the pairing response
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-10-19
- Weakness: CWE-863
Description
In the Linux kernel, the following vulnerability has been resolved: Bluetooth: SMP: force responder MITM requirements before building the pairing response smp_cmd_pairing_req() currently builds the pairing response from the initiator auth_req before enforcing the local BT_SECURITY_HIGH requirement. If the initiator omits SMP_AUTH_MITM, the response can also omit it even though the local side still requires MITM. tk_request() then sees an auth value without SMP_AUTH_MITM and may select JUST_CFM, making method selection inconsistent with the pairing policy the responder already enforces. When the local side requires HIGH security, first verify that MITM can be achieved from the IO capabilities and then force SMP_AUTH_MITM in the response in both rsp.auth_req and auth. This keeps the responder auth bits and later method selection aligned.
Affected products
- Linux kernel: from 3.3 before 5.10.253; from 5.11 before 5.15.203; from 5.16 before 6.1.168; from 6.2 before 6.6.134; from 6.7 before 6.12.81; from 6.13 before 6.18.22 — fixed in 5.10.253, 5.15.203, 6.1.168, 6.12.81, 6.18.22, 6.19.12
How to fix
Upgrade to a fixed version: Linux kernel 5.10.253, 5.15.203, 6.1.168, 6.12.81. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/01bb4045d2306c266178f49ce0c3576d237a3040
- https://git.kernel.org/stable/c/425a22c5373d4e1b46492ab869074ebeeade61f3
- https://git.kernel.org/stable/c/7ab69426e7ecbd18a222ee2ec87ca612d30197d7
- https://git.kernel.org/stable/c/91649c02c1baaa18cedf7fb425fa1f0f852c8183
- https://git.kernel.org/stable/c/c8ff0ca6508535bccabd81c5c9dcc63de8a3d4fb
- https://git.kernel.org/stable/c/d05111bfe37bfd8bd4d2dfe6675d6bdeef43f7c7
- https://git.kernel.org/stable/c/ec17efb1ef91506cfd17a77692eaf4bbacb520ea
- https://git.kernel.org/stable/c/fa14e0e19820b1bbdb42185c9c4efa950bcffef9
Get alerted when CVE-2026-43334 or the next vulnerability affects your stack