What’s Vulnerable › Vulnerabilities
CVE-2026-43387: staging: rtl8723bs: properly validate the data in rtw_get_ie_ex()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: staging: rtl8723bs: properly validate the data in rtw_get_ie_ex() Just like in commit 154828bf9559 ("staging: rtl8723bs: fix out-of-bounds read in rtw_get_ie() parser"), we don't trust the data in the frame so we should check the length better before acting on it
Affected products
- Linux kernel: from 4.12 before 5.10.253; from 5.11 before 5.15.203; from 5.16 before 6.1.167; from 6.2 before 6.6.130; from 6.7 before 6.12.78; from 6.13 before 6.18.19 — fixed in 5.10.253, 5.15.203, 6.1.167, 6.12.78, 6.18.19, 6.19.9
How to fix
Upgrade to a fixed version: Linux kernel 5.10.253, 5.15.203, 6.1.167, 6.12.78. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/35969c3a208a07cb8642301df5869c34e2db7071
- https://git.kernel.org/stable/c/6d62fa548387e159a21ea95132c09bfc96d336ed
- https://git.kernel.org/stable/c/740bca8bbdb707c0e4bb11e3316deb2f04fc7ce1
- https://git.kernel.org/stable/c/8097a48c606a9306281ea7bd73bf2afc97553733
- https://git.kernel.org/stable/c/821f7d759fb2de33c5e5b0c4981181c4d0c3e9b1
- https://git.kernel.org/stable/c/9a4cd4c37593cc8b8d28f9a6732b490a8032006a
- https://git.kernel.org/stable/c/ac38856092b4c994f94343251b30520bdeb7f475
- https://git.kernel.org/stable/c/f0109b9d3e1e455429279d602f6276e34689750a
Get alerted when CVE-2026-43387 or the next vulnerability affects your stack