What’s Vulnerable › Vulnerabilities
CVE-2026-43394: nfsd: Fix cred ref leak in nfsd_nl_listener_set_doit().
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: nfsd: Fix cred ref leak in nfsd_nl_listener_set_doit(). nfsd_nl_listener_set_doit() uses get_current_cred() without put_cred(). As we can see from other callers, svc_xprt_create_from_sa() does not require the extra refcount. nfsd_nl_listener_set_doit() is always in the process context, sendmsg(), and current->cred does not go away. Let's use current_cred() in nfsd_nl_listener_set_doit().
Affected products
- Linux kernel: from 6.10 before 6.12.78; from 6.13 before 6.18.19; from 6.19 before 6.19.9; 7.0-rc1, 7.0-rc2 — fixed in 6.12.78, 6.18.19, 6.19.9
How to fix
Upgrade to a fixed version: Linux kernel 6.12.78, 6.18.19, 6.19.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/019debe5851d7355bea9ff0248cc317878924d8f
- https://git.kernel.org/stable/c/02e87ec0bc706cb93fa47b43d18c4d10102c7d54
- https://git.kernel.org/stable/c/92978c83bb4eef55d02a6c990c01c423131eefa7
- https://git.kernel.org/stable/c/cba413765376bb466035c9160fa3130402971e2c
Get alerted when CVE-2026-43394 or the next vulnerability affects your stack