What’s Vulnerable › Vulnerabilities
CVE-2026-43406: libceph: prevent potential out-of-bounds reads in process_message_header()
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-10-19
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: libceph: prevent potential out-of-bounds reads in process_message_header() If the message frame is (maliciously) corrupted in a way that the length of the control segment ends up being less than the size of the message header or a different frame is made to look like a message frame, out-of-bounds reads may ensue in process_message_header(). Perform an explicit bounds check before decoding the message header.
Affected products
- Linux kernel: from 5.11 before 5.15.203; from 5.16 before 6.1.167; from 6.2 before 6.6.130; from 6.7 before 6.12.78; from 6.13 before 6.18.19; from 6.19 before 6.19.9 — fixed in 5.15.203, 6.1.167, 6.12.78, 6.18.19, 6.19.9, 6.6.130
How to fix
Upgrade to a fixed version: Linux kernel 5.15.203, 6.1.167, 6.12.78, 6.18.19. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/035867ae6f18df0aeedb2a57a5b74091bd4e3fe8
- https://git.kernel.org/stable/c/50156622eb0888e62541d715a98584480a1bc7cb
- https://git.kernel.org/stable/c/69fb5d91bba44ecf7eb80530b85fa4fb028921d5
- https://git.kernel.org/stable/c/69fe5af33fa3806f398d21c081d73c66e5523bc2
- https://git.kernel.org/stable/c/75582aaa580c11aed4c7731cad6b068b700e7efb
- https://git.kernel.org/stable/c/76ccf21a12c5f6d6790bc32c7da82446d877b2f4
- https://git.kernel.org/stable/c/dbd857a9e1e33ea71eaf3e211877027e533770d1
Get alerted when CVE-2026-43406 or the next vulnerability affects your stack