What’s Vulnerable › Vulnerabilities
CVE-2026-4342: ingress-nginx comment-based nginx configuration injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-19 · updated 2026-06-17
- Weakness: CWE-20
Description
A security issue was discovered in ingress-nginx where a combination of Ingress annotations can be used to inject configuration into nginx. This can lead to arbitrary code execution in the context of the ingress-nginx controller, and disclosure of Secrets accessible to the controller. (Note that in the default installation, the controller can access all Secrets cluster-wide.)
Affected products
- Kubernetes Nginx Ingress Controller: before 1.13.9; from 1.14.0 before 1.14.5; 1.15.0 — fixed in 1.13.9, 1.14.5
How to fix
Upgrade to a fixed version: Kubernetes Nginx Ingress Controller 1.13.9, 1.14.5. Check the vendor advisory for mitigations.
References
- https://github.com/kubernetes/kubernetes/issues/137893
- http://www.openwall.com/lists/oss-security/2026/03/19/9
Get alerted when CVE-2026-4342 or the next vulnerability affects your stack