What’s Vulnerable › Vulnerabilities
CVE-2026-43486: arm64: contpte: fix set_access_flags() no-op check for SMMU/ATS faults
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-13 · updated 2026-06-26
- Weakness: CWE-835
Description
In the Linux kernel, the following vulnerability has been resolved: arm64: contpte: fix set_access_flags() no-op check for SMMU/ATS faults contpte_ptep_set_access_flags() compared the gathered ptep_get() value against the requested entry to detect no-ops. ptep_get() ORs AF/dirty from all sub-PTEs in the CONT block, so a dirty sibling can make the target appear already-dirty. When the gathered value matches entry, the function returns 0 even though the target sub-PTE still has PTE_RDONLY set in hardware. For a CPU with FEAT_HAFDBS this gathered view is fine, since hardware may set AF/dirty on any sub-PTE and CPU TLB behavior is effectively gathered across the CONT range. But page-table walkers that evaluate each descriptor individually (e.g. a CPU without DBM support, or an SMMU without HTTU, or with HA/HD disabled in CD.TCR) can keep faulting on the unchanged target sub-PTE, causing an infinite fault loop. Gathering can therefore cause false no-ops when only a sibling has been updated: - write faults: target still has PTE_RDONLY (needs PTE_RDONLY cleared) - read faults: target still lacks PTE_AF Fix by checking each sub-PTE against the requested AF/dirty/write state (the same bits consumed by __ptep_set_access_flags()), using raw per-PTE values rather than the gathered ptep_get() view, before returning no-op. Keep using the raw target PTE for the write-bit unfold decision. Per Arm ARM (DDI 0487) D8.7.1 ("The Contiguous bit"), any sub-PTE in a CONT range may become the effective cached translation and software must maintain consistent attributes across the range.
Affected products
- Linux kernel: from 6.9 before 6.12.78; from 6.13 before 6.18.19; from 6.19 before 6.19.9; 7.0-rc1, 7.0-rc2 — fixed in 6.12.78, 6.18.19, 6.19.9
How to fix
Upgrade to a fixed version: Linux kernel 6.12.78, 6.18.19, 6.19.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/05d239f2c95e66e27e7fb4e99ee07eb56e3e34b0
- https://git.kernel.org/stable/c/09d620555e59768776090073a2c59d2bc8506eb3
- https://git.kernel.org/stable/c/6f92a7a8b48a523f910ef25dd83808710724f59b
- https://git.kernel.org/stable/c/97c5550b763171dbef61e6239cab372b9f9cd4a2
Get alerted when CVE-2026-43486 or the next vulnerability affects your stack