What’s Vulnerable › Vulnerabilities

CVE-2026-43513: Apache Tomcat: LockOutRealm treats user names as case-sensitive

Description

Improper Handling of Case Sensitivity vulnerability in LockOutRealm in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Older unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 9.0.118, 10.1.55, 11.0.22. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-43513 or the next vulnerability affects your stack