What’s Vulnerable › Vulnerabilities
CVE-2026-43569: OpenClaw < 2026.4.9 - Untrusted Provider Plugin Auto-enablement via Workspace Provider Auth
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-05 · updated 2026-06-17
- Weakness: CWE-829
Description
OpenClaw before 2026.4.9 contains an authentication bypass vulnerability allowing untrusted workspace plugins to be auto-enabled during non-interactive onboarding when provider auth choices are shadowed. Attackers can exploit this by crafting malicious workspace plugins that are automatically selected and enabled during authentication setup without explicit user consent.
Affected products
- OpenClaw: before 2026.4.9 — fixed in 2026.4.9
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/2d97eae53e212ae26f3aebcd6a50ffc6877f770d
- https://github.com/openclaw/openclaw/security/advisories/GHSA-939r-rj45-g2rj
- https://www.vulncheck.com/advisories/openclaw-untrusted-provider-plugin-auto-enablement-via-workspace-provider-auth
Get alerted when CVE-2026-43569 or the next vulnerability affects your stack