What’s Vulnerable › Vulnerabilities
CVE-2026-43584: OpenClaw < 2026.4.10 - Insufficient Environment Variable Denylist in Exec Policy
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-06 · updated 2026-06-17
- Weakness: CWE-184
Description
OpenClaw before 2026.4.10 contains an insufficient environment variable denylist vulnerability in its exec environment policy that allows operator-supplied overrides of high-risk interpreter startup variables including VIMINIT, EXINIT, LUA_INIT, and HOSTALIASES. Attackers can exploit this by manipulating these environment variables to influence downstream execution behavior or network connectivity.
Affected products
- OpenClaw: before 2026.4.10 — fixed in 2026.4.10
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.10. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/commit/2d126fc62343a7b6895351f96e4e1474bc358140
- https://github.com/openclaw/openclaw/security/advisories/GHSA-vfp4-8x56-j7c5
- https://www.vulncheck.com/advisories/openclaw-insufficient-environment-variable-denylist-in-exec-policy
Get alerted when CVE-2026-43584 or the next vulnerability affects your stack