What’s Vulnerable › Vulnerabilities
CVE-2026-4359: Heap-buffer-over-read in _mongoc_http_send via strstr on non-null-terminated buffer
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-17 · updated 2026-06-17
- Weakness: CWE-158
Description
A compromised third party cloud server or man-in-the-middle attacker could send a malformed HTTP response and cause a crash in applications using the MongoDB C driver.
Affected products
- MongoDB C# Driver: before 1.30.8; from 2.2.0 before 2.2.3 — fixed in 1.30.8, 2.2.3
How to fix
Upgrade to a fixed version: MongoDB C# Driver 1.30.8, 2.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-4359 or the next vulnerability affects your stack