What’s Vulnerable › Vulnerabilities
CVE-2026-43616: Detect-It-Easy < 3.21 Path Traversal Arbitrary File Write
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-04 · updated 2026-10-26
- Weakness: CWE-23
Description
Detect-It-Easy prior to 3.21 contains a path traversal vulnerability that allows attackers to write arbitrary files to the filesystem by crafting malicious archive entries with relative traversal sequences or absolute paths. Attackers can exploit insufficient path normalization during archive extraction to write files outside the intended extraction directory and achieve persistent code execution by overwriting user startup scripts.
Affected products
- horsicq Detect-It-Easy: before 3.21 — fixed in 3.21
How to fix
Upgrade to a fixed version: horsicq Detect-It-Easy 3.21. Check the vendor advisory for mitigations.
References
- https://github.com/horsicq/DIE-engine/commit/7fd300b926daf19707b2a36f0abe8b60a51308ee
- https://github.com/horsicq/DIE-engine/commit/cbbe1688e58ffd430d284bf65f336973f083db69
- https://github.com/horsicq/DIE-engine/releases/tag/3.21
- https://github.com/horsicq/Detect-It-Easy
- https://github.com/horsicq/Formats/commit/56cdf50ee3c72c56284e2819b23e98332842d259
- https://github.com/horsicq/XArchive/commit/6a2aa84c2fd120b704f76bb5c5ee3e9b5a7a0fcc
- https://www.vulncheck.com/advisories/detect-it-easy-path-traversal-arbitrary-file-write
Get alerted when CVE-2026-43616 or the next vulnerability affects your stack