What’s Vulnerable › Vulnerabilities

CVE-2026-43646: Apache Wicket: crafted URLs can bypass PackageResourceGuard

Description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, from 9.0.0 through 9.22.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Wicket 10.9.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-43646 or the next vulnerability affects your stack