What’s Vulnerable › Vulnerabilities
CVE-2026-43870: Apache Thrift: Node.js web_server.js multi-vulnerability
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-05 · updated 2026-10-26
- Weakness: CWE-22
Description
Origin Validation Error, Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting'), Uncontrolled Resource Consumption vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Thrift: before 0.23.0 — fixed in 0.23.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Thrift 0.23.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/pgtfq44ltc9t63kxcbqmwqzt45pnhqdy
- http://www.openwall.com/lists/oss-security/2026/05/05/4
Get alerted when CVE-2026-43870 or the next vulnerability affects your stack