What’s Vulnerable › Vulnerabilities
CVE-2026-43886: Outline: OAuth Scope Validation Logic Error Allows Privilege Escalation to Wildcard API Access
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-11 · updated 2026-06-17
- Weakness: CWE-269
Description
Outline is a service that allows for collaborative documentation. From 0.84.0 to 1.6.1, a logic error in OAuthInterface.validateScope() uses Array.some() to validate requested OAuth scopes, causing the function to accept the entire scope array if any single scope is valid. An attacker can smuggle the wildcard * scope by requesting scope=read *, escalating a read-only OAuth token to full unrestricted API access including write, delete, and admin operations. This vulnerability is fixed in 1.7.0.
Affected products
- outline: from 0.84.0, < 1.7.0
References
- https://github.com/outline/outline/security/advisories/GHSA-7732-6qrg-wjf4
- https://github.com/outline/outline/security/advisories/GHSA-7732-6qrg-wjf4
Get alerted when CVE-2026-43886 or the next vulnerability affects your stack