What’s Vulnerable › Vulnerabilities
CVE-2026-43914: Vaultwarden: Brute-force protection bypass vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-11 · updated 2026-10-26
- Weakness: CWE-307
Description
Vaultwarden is a Bitwarden-compatible server written in Rust. Prior to 1.35.4, there is a security vulnerability in Vaultwarden that allows bypassing the login brute-force protection if email 2fa is enabled. If email 2fa is enabled, the unprotected 2fa-function send_email_login (email.rs, api endpoint /api/two-factor/send-email-login) also acts as an oracle determining whether a username-password combination is correct. An attacker can abuse that endpoint to brute-force passwords without rate-limiting. This works even for users who don't have email 2fa configured. This vulnerability is fixed in 1.35.4.
Affected products
- dani-garcia vaultwarden: before 1.35.4 — fixed in 1.35.4
How to fix
Upgrade to a fixed version: dani-garcia vaultwarden 1.35.4. Check the vendor advisory for mitigations.
References
- https://github.com/dani-garcia/vaultwarden/pull/6867
- https://github.com/dani-garcia/vaultwarden/releases/tag/1.35.4
- https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-c5rv-q295-7w4g
- https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-c5rv-q295-7w4g
Get alerted when CVE-2026-43914 or the next vulnerability affects your stack