What’s Vulnerable › Vulnerabilities
CVE-2026-43934: e107: Broken Access Control in e107 comment edit allows cross-user comment modification
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-26 · updated 2026-07-24
- Weakness: CWE-284
Description
e107 is a content management system (CMS). Prior to 2.3.4, a Broken Access Control vulnerability exists in the application, allowing an unauthorized authenticated user to edit comments posted by others. This stems from inadequate server-side access control validation, where the application depends only on a predictable identifier in the request to determine which comment to edit, without confirming the requesting user’s ownership of the comment. This vulnerability is fixed in 2.3.4.
Affected products
- e107inc e107: before 2.3.4
References
- https://github.com/e107inc/e107/commit/23961a8f
- https://github.com/e107inc/e107/security/advisories/GHSA-5w63-63rh-99q6
- https://github.com/e107inc/e107/security/advisories/GHSA-5w63-63rh-99q6
Get alerted when CVE-2026-43934 or the next vulnerability affects your stack