What’s Vulnerable › Vulnerabilities
CVE-2026-43940: electerm: Path traversal in electerm runWidget leads to arbitrary code execution
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-06-17
- Weakness: CWE-22
Description
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.7.16, the runWidget function in src/app/widgets/load-widget.js constructs a file path by directly concatenating user‑supplied widget identifiers without any sanitisation. Because runWidget is exposed to the renderer process via an asynchronous IPC handler with no input validation, an attacker who achieves JavaScript execution inside the renderer (for example, through a malicious plugin or a cross‑site scripting flaw in the built‑in webview) can abuse a path traversal (../) to load and execute an arbitrary JavaScript file anywhere on the victim’s filesystem. This gives the attacker local code execution with the full privileges of the electerm process, leading to complete system compromise. This issue has been patched in version 3.7.16.
Affected products
- electerm: before 3.7.16 — fixed in 3.7.16
How to fix
Upgrade to a fixed version: electerm 3.7.16. Check the vendor advisory for mitigations.
References
- https://github.com/electerm/electerm/releases/tag/v3.7.16
- https://github.com/electerm/electerm/security/advisories/GHSA-f77v-9vpc-6pjm
Get alerted when CVE-2026-43940 or the next vulnerability affects your stack