What’s Vulnerable › Vulnerabilities
CVE-2026-43944: electerm: dangerous code can be run through links or command line
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-06-17
- Weakness: CWE-20
Description
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.
Affected products
- electerm: from 3.0.6 before 3.8.15 — fixed in 3.8.15
How to fix
Upgrade to a fixed version: electerm 3.8.15. Check the vendor advisory for mitigations.
References
- https://github.com/electerm/electerm/commit/0599e67069b00e376a2e962649aaad6096e63507
- https://github.com/electerm/electerm/commit/8a6a17951e96d715f5a231532bbd8303fe208700
- https://github.com/electerm/electerm/commit/a79e06f4a1f0ac6376c3d2411ef4690fa0377742
- https://github.com/electerm/electerm/releases/tag/v3.8.15
- https://github.com/electerm/electerm/security/advisories/GHSA-mpm8-cx2p-626q
Get alerted when CVE-2026-43944 or the next vulnerability affects your stack