What’s Vulnerable › Vulnerabilities
CVE-2026-43961: Vim: vimscript injection via unescaped filename in netrw s:netrwmarkfile() filter() expression allows arbitrary code execution
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-10-30
- Weakness: CWE-94
Description
A flaw was found in Vim's netrw plugin. A crafted filename containing quote characters and expression fragments can break out of the quoted context during mark/unmark operations, allowing arbitrary Vimscript execution. This can be leveraged to run shell commands with the privileges of the user running Vim.
Affected products
- Red Hat Enterprise Linux 10: all versions
- Red Hat Enterprise Linux 7: all versions
- Red Hat Enterprise Linux 8: all versions
- Red Hat Enterprise Linux 9: all versions
- Red Hat Hardened Images: all versions — fixed in 9.2.967-1.1.hum1
- vim/vim: before 9.2.0480 — fixed in 9.2.0480
How to fix
Upgrade to a fixed version: Red Hat Hardened Images 9.2.967-1.1.hum1; vim/vim 9.2.0480. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:57614
- https://access.redhat.com/security/cve/CVE-2026-43961
- https://bugzilla.redhat.com/show_bug.cgi?id=2460434
- https://github.com/vim/vim/security/advisories/GHSA-66hr-7p6x-x5j3
- http://www.openwall.com/lists/oss-security/2026/05/14/7
Get alerted when CVE-2026-43961 or the next vulnerability affects your stack