What’s Vulnerable › Vulnerabilities
CVE-2026-43965: Path Traversal in build/packages/packages.toml Allows Arbitrary Directory Deletion
- Severity: medium (CVSS 5.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-02 · updated 2026-10-06
- Weakness: CWE-22
Description
Path traversal vulnerability in Gleam's dependency management allows arbitrary directory deletion via malicious build/packages/packages.toml content. Package keys read from build/packages/packages.toml by LocalPackages::read_from_disc are passed without validation to paths.build_packages_package(), which constructs a filesystem path by joining the project build directory with the attacker-controlled key. The resulting path is then passed to fs::delete_directory (which calls remove_dir_all). No check is performed to ensure the path remains within the intended build/packages/ directory. Both absolute paths and relative traversal sequences (e.g. ../) are accepted as package keys, allowing deletion of arbitrary directories. An attacker who can cause a victim to run gleam deps download on a project containing a malicious build/packages/packages.toml (e.g. by committing the normally-gitignored file to a repository) can cause arbitrary directories on the victim's system to be recursively deleted. This issue affects Gleam from 0.18.0-rc1 until 1.17.0.
Affected products
- Gleam: from 0.18.0-rc1 before 1.17.0; from v0.18.0-rc1-elixir before v1.17.0-elixir; from v0.18.0-rc1-erlang before v1.17.0-erlang; from v0.18.0-rc1-node before v1.17.0-node; from v0.18.0-rc1-node-slim before v1.17.0-node-slim; from v0.18.0-rc1-elixir-slim before v1.17.0-elixir-slim — fixed in 1.17.0, v1.17.0-elixir, v1.17.0-elixir-alpine, v1.17.0-elixir-slim, v1.17.0-erlang, v1.17.0-erlang-alpine
How to fix
Upgrade to a fixed version: Gleam 1.17.0, v1.17.0-elixir, v1.17.0-elixir-alpine, v1.17.0-elixir-slim. Check the vendor advisory for mitigations.
References
- https://cna.erlef.org/cves/CVE-2026-43965.html
- https://github.com/gleam-lang/gleam/commit/690ca069817bee5f77a28fc3e360627c1da19291
- https://github.com/gleam-lang/gleam/security/advisories/GHSA-jqvf-f6p2-wrv3
- https://osv.dev/vulnerability/EEF-CVE-2026-43965
- https://github.com/gleam-lang/gleam/security/advisories/GHSA-jqvf-f6p2-wrv3
Get alerted when CVE-2026-43965 or the next vulnerability affects your stack