What’s Vulnerable › Vulnerabilities
CVE-2026-44007: vm2: nesting: true bypasses require: false, allowing sandbox escape to arbitrary OS command execution
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-284
Description
vm2 is an open source vm/sandbox for Node.js. Prior to 3.11.1, when a NodeVM is created with nesting: true, sandbox code can unconditionally require('vm2') regardless of the outer VM's require configuration — including require: false. With access to vm2, the sandbox constructs a new inner NodeVM with its own unrestricted require settings and executes arbitrary OS commands on the host. Any application that runs untrusted code inside a NodeVM with nesting: true is fully compromised. This vulnerability is fixed in 3.11.1.
Affected products
- patriksimek vm2: before 3.11.1 — fixed in 3.11.1
How to fix
Upgrade to a fixed version: patriksimek vm2 3.11.1. Check the vendor advisory for mitigations.
References
- https://github.com/patriksimek/vm2/security/advisories/GHSA-8hg8-63c5-gwmx
- http://www.openwall.com/lists/oss-security/2026/05/05/11
- https://access.redhat.com/errata/RHSA-2026:50850
- https://access.redhat.com/security/cve/CVE-2026-44007
- https://bugzilla.redhat.com/show_bug.cgi?id=2477198
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44007.json
Get alerted when CVE-2026-44007 or the next vulnerability affects your stack