What’s Vulnerable › Vulnerabilities
CVE-2026-44016: Docling: Unsafe Playwright-based HTML Rendering
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-24 · updated 2026-10-23
- Weakness: CWE-94
Description
Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. FIn versions >= 2.82.0, < 2.91.0, if the HTML backend was explicitly configured for rendering (rendering option by default deactivated), then the Playwright-based rendering feature could allow JavaScript execution and unrestricted network access when processing untrusted HTML documents. An attacker could craft malicious HTML that executes arbitrary JavaScript in the rendering context or makes unauthorized network requests to internal services, potentially leading to SSRF attacks, data exfiltration, or remote code execution in the rendering environment. This vulnerability is fixed in 2.91.0.
Affected products
- docling-project docling: from 2.82.0 before 2.91.0 — fixed in 2.91.0
How to fix
Upgrade to a fixed version: docling-project docling 2.91.0. Check the vendor advisory for mitigations.
References
- https://github.com/docling-project/docling/releases/tag/v2.91.0
- https://github.com/docling-project/docling/security/advisories/GHSA-pj2v-ggqh-cmq2
- https://access.redhat.com/security/cve/CVE-2026-44016
- https://bugzilla.redhat.com/show_bug.cgi?id=2492339
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44016.json
Get alerted when CVE-2026-44016 or the next vulnerability affects your stack