What’s Vulnerable › Vulnerabilities
CVE-2026-44024: Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-22
Description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd allows dynamically constructing file paths using the ${tag} placeholder, and insufficient validation of ${tag} in file configurations such as the path parameter of the out_file plugin allows attackers sending untrusted tags containing path traversal characters to write or overwrite arbitrary files and potentially achieve remote code execution. This issue is fixed in version 1.19.3.
Affected products
- fluentd: before 1.19.3 — fixed in 1.19.3
How to fix
Upgrade to a fixed version: fluentd 1.19.3. Check the vendor advisory for mitigations.
References
- https://github.com/fluent/fluentd/commit/45c87a81f3ac0b72b3f9dcfe8cfb5f9038f81437
- https://github.com/fluent/fluentd/pull/5391
- https://github.com/fluent/fluentd/releases/tag/v1.19.3
- https://github.com/fluent/fluentd/security/advisories/GHSA-44hj-4m45-frj3
Get alerted when CVE-2026-44024 or the next vulnerability affects your stack