What’s Vulnerable › Vulnerabilities
CVE-2026-44025: Fluentd: Exposure of Sensitive Information via Monitor Agent API
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-306
Description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's Monitor Agent plugin in_monitor_agent exposes internal metrics and plugin information via a REST API, and responses from /api/plugins.json and related endpoints unintentionally include internal instance variables that may contain database passwords, API keys, or cloud credentials. This issue is fixed in version 1.19.3.
Affected products
- fluentd: before 1.19.3 — fixed in 1.19.3
How to fix
Upgrade to a fixed version: fluentd 1.19.3. Check the vendor advisory for mitigations.
References
- https://github.com/fluent/fluentd/commit/990921518971699b9a97441970674d1800e29177
- https://github.com/fluent/fluentd/pull/5392
- https://github.com/fluent/fluentd/releases/tag/v1.19.3
- https://github.com/fluent/fluentd/security/advisories/GHSA-pr7j-96cj-549h
Get alerted when CVE-2026-44025 or the next vulnerability affects your stack