What’s Vulnerable › Vulnerabilities
CVE-2026-44028
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-05 · updated 2026-10-26
- Weakness: CWE-674
Description
An issue was discovered in Nix before 2.34.7 and Lix before 2.95.2. Unbounded recursion in the NAR (Nix Archive) parser could lead to a stack-to-heap overflow when the parser is run on a coroutine stack. The stack is allocated without a guard page, which means that a stack overflow could overwrite memory on the heap and could allow arbitrary code execution as the Nix daemon (run as root in multi-user installations) if ASLR hardening is bypassed. This can be exploited by all users able to connect to the daemon (e.g., in Nix, this is configurable via the allowed-users setting, defaulting to all users). The fixed versions are 2.34.7, 2.33.6, 2.32.8, 2.31.5, 2.30.5, 2.29.4, and 2.28.7 for Nix (introduced in 2.24.4); and 2.95.2, 2.94.2, and 2.93.4 for Lix (introduced in 2.93.0).
Affected products
- Lix Project Lix: from 2.93.0 before 2.93.4; from 2.94.0 before 2.94.2; from 2.95.0 before 2.95.2 — fixed in 2.93.4, 2.94.2, 2.95.2
- NixOS Nix: from 2.24.4 before 2.28.7; from 2.29.0 before 2.29.4; from 2.30.0 before 2.30.5; from 2.31.0 before 2.31.5; from 2.32.0 before 2.32.8; from 2.33.0 before 2.33.6 — fixed in 2.28.7, 2.29.4, 2.30.5, 2.31.5, 2.32.8, 2.33.6
How to fix
Upgrade to a fixed version: Lix Project Lix 2.93.4, 2.94.2, 2.95.2; NixOS Nix 2.28.7, 2.29.4, 2.30.5, 2.31.5. Check the vendor advisory for mitigations.
References
- https://discourse.nixos.org/t/security-advisory-local-privilege-escalation-in-lix-and-nix/77407
- https://github.com/NixOS/nix/security/advisories/GHSA-vh5x-56v6-4368
- https://lix.systems/blog/2026-05-05-lix-unsigned-integer-overflow/
- https://www.openwall.com/lists/oss-security/2026/05/04/32
- https://www.openwall.com/lists/oss-security/2026/05/04/33
Get alerted when CVE-2026-44028 or the next vulnerability affects your stack