What’s Vulnerable › Vulnerabilities

CVE-2026-44029

Description

An issue was discovered in Nix before 2.34.7. Writing to arbitrary files can occur via "nix-prefetch-url --unpack" or "nix store prefetch-file --unpack" directory traversal. The fixed versions are 2.34.7, 2.33.6, 2.32.8, 2.31.5, 2.30.5, 2.29.4, and 2.28.7 (introduced in 2.24.7);

Affected products

How to fix

Upgrade to a fixed version: NixOS Nix 2.28.7, 2.29.4, 2.30.5, 2.31.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-44029 or the next vulnerability affects your stack