What’s Vulnerable › Vulnerabilities

CVE-2026-44046: Apache APISIX: wolf-rbac plugin Identity Spoofing

Description

Use of Less Trusted Source vulnerability in Apache APISIX. Attacker can take advantage of wolf-rbac plugin under default configuration to potentially pollute logs with spoofed identity information and exploit IP based access control rules. This issue affects Apache APISIX: from 1.2.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.17.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-44046 or the next vulnerability affects your stack