What’s Vulnerable › Vulnerabilities
CVE-2026-44160: Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-409
Description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's in_http and in_forward plugins support gzip-compressed data but enforce limits only on compressed payloads through settings such as body_size_limit and chunk_size_limit, allowing crafted compressed payloads to decompress in memory to an excessive size and cause denial of service through memory exhaustion. This issue is fixed in version 1.19.3.
Affected products
- fluentd: before 1.19.3 — fixed in 1.19.3
How to fix
Upgrade to a fixed version: fluentd 1.19.3. Check the vendor advisory for mitigations.
References
- https://github.com/fluent/fluentd/commit/f5f2b7cddf8aab3932e6dec9fa367a5f3eb27e10
- https://github.com/fluent/fluentd/pull/5393
- https://github.com/fluent/fluentd/releases/tag/v1.19.3
- https://github.com/fluent/fluentd/security/advisories/GHSA-j9cw-hwqf-85w7
Get alerted when CVE-2026-44160 or the next vulnerability affects your stack