What’s Vulnerable › Vulnerabilities
CVE-2026-44161: Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-918
Description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, the Fluentd out_http output plugin allows placeholders such as ${tag} in the endpoint configuration parameter, and if a placeholder value is derived from untrusted input an attacker can control the destination hostname of outbound HTTP requests and force requests to arbitrary internal services. This issue is fixed in version 1.19.3.
Affected products
- fluentd: before 1.19.3 — fixed in 1.19.3
How to fix
Upgrade to a fixed version: fluentd 1.19.3. Check the vendor advisory for mitigations.
References
- https://github.com/fluent/fluentd/commit/c6a01ea2e0ea01977f8d615f7c6dbfae4cba88c9
- https://github.com/fluent/fluentd/pull/5394
- https://github.com/fluent/fluentd/releases/tag/v1.19.3
- https://github.com/fluent/fluentd/security/advisories/GHSA-72f5-rr8c-r6gr
Get alerted when CVE-2026-44161 or the next vulnerability affects your stack