What’s Vulnerable › Vulnerabilities
CVE-2026-44162: fluent-plugin-s3: Denial of Service (DoS) via Decompression Bomb in `in_s3`
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-14 · updated 2026-09-30
- Weakness: CWE-409
Description
fluent-plugin-s3 is an Amazon S3 input and output plugin for Fluentd. From 0.7.0 to 1.8.4, the in_s3 input plugin reads the entire decompressed payload of gzip, lzma2, and lzop objects into memory without enforcing a decompression_size_limit. An attacker with permission to upload objects to the monitored S3 bucket can provide a highly compressed object that expands excessively when Fluentd processes it. The resulting memory exhaustion can cause the operating system to terminate the Fluentd process and disrupt all log collection on the affected node. This issue is fixed in version 1.8.5.
Affected products
- fluent-plugin-s3: from 0.7.0, < 1.8.5
References
- https://github.com/fluent/fluent-plugin-s3/commit/e085aee001d15bcc4bd073507e74075e30550fd0
- https://github.com/fluent/fluent-plugin-s3/releases/tag/v1.8.5
- https://github.com/fluent/fluent-plugin-s3/security/advisories/GHSA-xv9w-7v6q-hpjh
Get alerted when CVE-2026-44162 or the next vulnerability affects your stack