What’s Vulnerable › Vulnerabilities
CVE-2026-44166: Pocketbase: Account pre-hijacking via OAuth2 unverfied->verified autolinking upgrade
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-12 · updated 2026-06-17
- Weakness: CWE-287
Description
Pocketbase is an open source web backend written in go. Prior to 0.22.42 and 0.37.4, in some situations, if an attacker knows the email address of the victim they can create and link an unverified PocketBase user in advance by authenticating with one of the OAuth2 app providers, e.g. "A". When the victim gets invited or decides to sign up to your app on their own with provider "B" (PocketBase OAuth2 auth requires to be with a different provider because we don't allow multiple OAuth2 accounts from the same provider to be associated to a single PocketBase user), the user created previously by the attacker will be autolinked, upgraded to "verified" and its old password reset. This vulnerability is fixed in 0.22.42 and 0.37.4.
Affected products
- pocketbase: before 0.22.42; from 0.23.0 before 0.37.4 — fixed in 0.22.42, 0.37.4
How to fix
Upgrade to a fixed version: pocketbase 0.22.42, 0.37.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-44166 or the next vulnerability affects your stack