What’s Vulnerable › Vulnerabilities
CVE-2026-44193: OPNsense: RCE via XMLRPC endpoint using `opnsense.restore_config_section` method
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-88
Description
OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.7, the XMLRPC method opnsense.restore_config_section fails to sanitize user supplied input leading to Remote Code Execution. This vulnerability is fixed in 26.1.7.
Affected products
- OPNsense: before 26.1.7 — fixed in 26.1.7
How to fix
Upgrade to a fixed version: OPNsense 26.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/opnsense/core/security/advisories/GHSA-xxp9-93cr-x54p
- https://github.com/opnsense/core/security/advisories/GHSA-xxp9-93cr-x54p
Get alerted when CVE-2026-44193 or the next vulnerability affects your stack