What’s Vulnerable › Vulnerabilities
CVE-2026-44194: OPNsense: RCE on user managment
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-13 · updated 2026-10-26
- Weakness: CWE-78
Description
OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, an authenticated Remote Code Execution (RCE) vulnerability in the OPNsense core allows a user with user-management privileges to execute arbitrary system commands as root. An attacker can bypass input validation by formatting their malicious payload as a compliant email address, allowing shell commands to reach the underlying operating system. The flaw exists in the local user synchronization flow, within core/src/opnsense/scripts/auth/sync_user.php. This vulnerability is fixed in 26.1.8.
Affected products
- OPNsense: before 26.1.8 — fixed in 26.1.8
How to fix
Upgrade to a fixed version: OPNsense 26.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/opnsense/core/security/advisories/GHSA-f59w-m967-9rf6
- https://github.com/opnsense/core/security/advisories/GHSA-f59w-m967-9rf6
Get alerted when CVE-2026-44194 or the next vulnerability affects your stack