What’s Vulnerable › Vulnerabilities
CVE-2026-44264: Weblate is vulnerable to XSS via crafted Markdown
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-07 · updated 2026-10-26
- Weakness: CWE-80
Description
Weblate is a web based localization tool. Prior to version 5.17.1, the Markdown renderer used in user comments and other user-provided content didn't properly sanitize some attributes. This issue has been patched in version 5.17.1.
Affected products
- WeblateOrg weblate: before 5.17.1 — fixed in 5.17.1
How to fix
Upgrade to a fixed version: WeblateOrg weblate 5.17.1. Check the vendor advisory for mitigations.
References
- https://github.com/WeblateOrg/weblate/commit/85abc9df88b7464f4c0e794aef752e45f4230f75
- https://github.com/WeblateOrg/weblate/pull/19259
- https://github.com/WeblateOrg/weblate/releases/tag/weblate-5.17.1
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-5cmv-3rc4-7279
Get alerted when CVE-2026-44264 or the next vulnerability affects your stack