What’s Vulnerable › Vulnerabilities
CVE-2026-44282: Election question titles allow stored script execution
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-30
- Weakness: CWE-79
Description
Decidim is a participatory democracy framework. Prior to 0.32.0, a low-privilege process-scoped administrator or election editor with question-management rights can store HTML or script-bearing content in question.body. The question_title helper returns the translatable question body through html_safe without a sanitization boundary, causing stored script execution when visitors open public election pages or voting booth screens. The persisted script executes in visitors' browsers. The vulnerability is fixed in 0.32.0.
Affected products
- decidim: before 0.32.0
References
- https://github.com/decidim/decidim/commit/64dbea3739f360f1eb36932dfc49d9686e61fc00
- https://github.com/decidim/decidim/commit/b6e1b003365d10c0df2bc7edc5edd26b62fafda1
- https://github.com/decidim/decidim/pull/16659
- https://github.com/decidim/decidim/pull/16669
- https://github.com/decidim/decidim/releases/tag/v0.32.0
- https://github.com/decidim/decidim/security/advisories/GHSA-9mvp-w4rr-5c6x
Get alerted when CVE-2026-44282 or the next vulnerability affects your stack