What’s Vulnerable › Vulnerabilities
CVE-2026-44312: css_parser allows to MITM included https css urls
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-10-26
- Weakness: CWE-295
Description
css_parser is a Ruby CSS parser. Prior to 2.1.0 and 1.22.0, the CSS Parser gem does not validate HTTPS connections, allowing a Man-in-the-Middle (MITM) attacker to inject or modify CSS content when stylesheets are loaded via HTTPS. The connection is established with OpenSSL::SSL::VERIFY_NONE, meaning any HTTPS certificate—even entirely untrusted—will be accepted without validation. This vulnerability is fixed in 2.1.0 and 1.22.0.
Affected products
- Rubygems Css Parser: from 2.0.0 before 2.1.0; before 1.22.0; 2.0.0, 0.9.0, 0.9.1, 1.0.0, 1.0.1, 1.1.1 (+55) — fixed in 2.1.0, 1.22.0
- premailer css_parser: from 2.0.0, < 2.1.0; before 1.22.0
How to fix
Upgrade to a fixed version: Rubygems Css Parser 2.1.0, 1.22.0. Check the vendor advisory for mitigations.
References
- https://github.com/premailer/css_parser/commit/35e689c904225add78e0c488cf04bad052666449
- https://github.com/premailer/css_parser/commit/e0c95d5abe91b237becb90ff316531a6547ada18
- https://github.com/premailer/css_parser/issues/185
- https://github.com/premailer/css_parser/security/advisories/GHSA-ff6c-w6qf-7xqc
- https://github.com/premailer/css_parser/security/advisories/GHSA-ff6c-w6qf-7xqc
Get alerted when CVE-2026-44312 or the next vulnerability affects your stack